Author Topic: access violation again (new one)  (Read 562 times)

andrew.nao1

  • Member
  • *
  • Posts: 34
access violation again (new one)
« on: May 01, 2014, 07:42:02 AM »
attached is the error i get along with the files
its a simple cut n paste

in the acad text window this is appeared

Command: (load "cutnpaste")
C:CUTNPASTE_CUTNPASTE_SLIDEVIEW2_ONCLICKED

Command: cutnpaste
; error: bad xsubr(L) instruction (offs code):  18429 0

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2549
    • Outside The Box
Re: access violation again (new one)
« Reply #1 on: May 01, 2014, 07:47:47 AM »
Is this in AutoCAD 2015? Which Windows version and architecture?

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2549
    • Outside The Box
Re: access violation again (new one)
« Reply #2 on: May 01, 2014, 07:53:47 AM »
I could not reproduce the problem. I commented out the references to missing files in your lisp code, started AutoCAD 2015, loaded the .lsp, and entered the cutnpaste command. The form displayed. I clicked on one of the buttons, and the form closed. I then closed AutoCAD.

andrew.nao1

  • Member
  • *
  • Posts: 34
Re: access violation again (new one)
« Reply #3 on: May 01, 2014, 07:56:43 AM »
Is this in AutoCAD 2015? Which Windows version and architecture?
yes this is acad 2015
window 7 64 bit


FTR, when i open the odcl files in the alpha version of the studio and save them
and try to run them in acad 2014. they wont load at all

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2549
    • Outside The Box
Re: access violation again (new one)
« Reply #4 on: May 01, 2014, 09:07:37 AM »
I opened cutnpaste.odcl in OpenDCL Studio 8.0.0.6, saved it, exited Studio, started AutoCAD 2014, loaded cutnpaste.lsp, entered the cutnpaste command, and the form displayed without error.

andrew.nao1

  • Member
  • *
  • Posts: 34
Re: access violation again (new one)
« Reply #5 on: May 02, 2014, 06:18:06 AM »
I opened cutnpaste.odcl in OpenDCL Studio 8.0.0.6, saved it, exited Studio, started AutoCAD 2014, loaded cutnpaste.lsp, entered the cutnpaste command, and the form displayed without error.

yes, it work no problem in 2014..

2015 is the issue

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2549
    • Outside The Box
Re: access violation again (new one)
« Reply #6 on: May 02, 2014, 08:05:12 AM »
yes, it work no problem in 2014..
2015 is the issue

You said in the previous message that it fails in AutoCAD 2014. Please clarify.

andrew.nao1

  • Member
  • *
  • Posts: 34
Re: access violation again (new one)
« Reply #7 on: May 02, 2014, 08:15:57 AM »
yes, it work no problem in 2014..
2015 is the issue

You said in the previous message that it fails in AutoCAD 2014. Please clarify.

no sir, no mention of 2014 with this particular issue

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2549
    • Outside The Box
Re: access violation again (new one)
« Reply #8 on: May 02, 2014, 08:36:07 AM »
FTR, when i open the odcl files in the alpha version of the studio and save them
and try to run them in acad 2014. they wont load at all

Please clarify what you meant.

andrew.nao1

  • Member
  • *
  • Posts: 34
Re: access violation again (new one)
« Reply #9 on: May 02, 2014, 09:16:04 AM »
FTR, when i open the odcl files in the alpha version of the studio and save them
and try to run them in acad 2014. they wont load at all

Please clarify what you meant.
my mistake, i misunderstood since i have 2 issues going.

when the odcl files are opened and saved in vers 8 studio then i run "cutnpaste" in 2014, i get the above error and then "project cannot be loaded"
if i open the files in ver7 studio and save them, they work fine

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2549
    • Outside The Box
Re: access violation again (new one)
« Reply #10 on: May 02, 2014, 09:21:07 AM »
Since I could not reproduce the problem, there is either a missing step, something specific to your environment, or human error. I recommend to try the steps on a different system to see if you can reproduce it.

andrew.nao1

  • Member
  • *
  • Posts: 34
Re: access violation again (new one)
« Reply #11 on: May 02, 2014, 10:38:45 AM »
made a new odcl file.
this wont load at all in 2015. can you see if it loads for you

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2549
    • Outside The Box
Re: access violation again (new one)
« Reply #12 on: May 03, 2014, 01:04:09 AM »
I commented out the references to missing files, then loaded the lisp file and entered CUTPAS. It displayed the dialog as expected. If I click on any button, the dialog closes.

andrew.nao1

  • Member
  • *
  • Posts: 34
Re: access violation again (new one)
« Reply #13 on: May 05, 2014, 06:40:25 AM »
i wont for me, ive uninstalled odcl and acad 2015 cleaned out the registry and reinstalled.

still the same

owenwengerd

  • Administrator
  • Hero Member
  • *****
  • Posts: 2549
    • Outside The Box
Re: access violation again (new one)
« Reply #14 on: May 05, 2014, 06:54:22 AM »
Have you done exactly what I did? Have you tested on other systems? If you can find one that works and one that doesn't, then you can compare the differences to find the missing ingredient.